Error while saving the email server details : Duplicate entry for key

Error while saving the email server details : Duplicate entry for key

This Problem may happen when the application is holding to different mail server details.






1- So go to Reports > New query report and execute the following query :

    select * from IncomingMailServer





2- If you see multiple mail server configured in this, Then connect to the database.

3- Now execute the following query :

  delete from incomingmailserver where serverid=305 ; 

 Where serverid= the id of host name you need to delete .

4-Then Restart the service once and Then the mail fetching will work.